Appium Studio – Appium – Eclipse – TestNG – Parameter Issues

Hello,

I am facing so many issues in using appium studio community edition -appium and eclipse. following are details;

  • I have recorded one script in Testng in appium studio by using an app(.apk) installed and launching on my real device.
  • Copy paste it in eclipse in java class under java project by adding reference libraries.
  • Then make few text changes like data / description and saved and run it on same real device.                                                                                                                                  Issues I am facing;
  1. Appium studio constantly showing an emulator (opened from AVD of eclipse) offline.
  2. If my appium studio is opened with my device opened and I run the script in java then no actions happened
  3. If appium studio is opened with my device opened and try to start the appium server it gives some wierd error and on closing appium studio it starts smoothly..
  4. I could run the recorded and edited script only at once when appium server / appium studio and my device is opened but second time on-words i am receiving one constant error (Caused by: org.openqa.selenium.NoSuchElementException: An element could not be located on the page using the given search parameters. (WARNING: The server did not provide any stacktrace information)) 
  5. I installed an test apk on an emulator(from AVD), now when trying to run that its giving an error with activity name and app package.I put same app package and app activity name as recorded for real device. I checked under UIAutomator about the apppackage then its showing android launcher then I made changes accordingly then apppackage error disappear now only appactivity error left. but how to get app activity name for the same app on emulator?is it different from real device.?

I tried with different versions of appium 1.5 to 1.7. on three different machines with Windows7, windows8.and windows10. As it runs fine and smooth for 5 mins with long workflow, I think configuration is fine.

I tried to search across many forums but no satisfactory solution. Any proper solutuion? Thanks!

Default Asked on April 17, 2018 in Appium.
Add Comment
  • 1 Answer(s)

    make sure you are using Appium Studio plugins for Eclipse and configure the project to mobile nature.

    Default Answered on April 18, 2018.
    Add Comment
  • Your Answer

    By posting your answer, you agree to the privacy policy and terms of service.