-Appium parallel test setup issue

Hi All,

 

After following this article I am trying to run my script on two Android devices.

http://toolsqa.com/mobile-automation/appium/appium-parallel-execution-using-testng/

I created one maven project and did all the setting which are mentioned in the above article, but every time script is running in 1 device only, find below the appium log error which I am getting in one appium server
ers\sanjay>appium -a 127.0.0.1 -p 4760 -cp 4760
[Appium] Welcome to Appium v1.6.5-beta
[Appium] Non-default server args:
[Appium] address: 127.0.0.1
[Appium] port: 4760
[Appium] callbackPort: 4760
[Appium] Appium REST http interface listener started on 127.0.0.1:4760
[HTTP] –> POST /wd/hub/session {“capabilities”:[{“desiredCapabilities”:{“appPackage”:”com.boutiqaat.boutiqaat”,”appActivity”:”com.boutiqaat.boutiqaat.activity.HomeActivity”,”AndroidMobileCapabilityType.SYSTEM_PORT”:”4760″,”newCommandTimeout”:0,”platformVersion”:”7.0″,”automationName”:”uiautomator2″,”udid”:”10160adb37840903″,”platformName”:”Android”,”deviceName”:”Galaxt Note5″}},{“requiredCapabilities”:{}}],”desiredCapabilities”:{“appPackage”:”com.boutiqaat.boutiqaat”,”appActivity”:”com.boutiqaat.boutiqaat.activity.HomeActivity”,”AndroidMobileCapabilityType.SYSTEM_PORT”:”4760″,”newCommandTimeout”:0,”platformVersion”:”7.0″,”automationName”:”uiautomator2″,”udid”:”10160adb37840903″,”platformName”:”Android”,”deviceName”:”Galaxt Note5″},”requiredCapabilities”:{}}
[debug] [MJSONWP] Calling AppiumDriver.createSession() with args: [{“appPackage”:”com.boutiqaat.boutiqaat”,”appActivity”:”com.boutiqaat.boutiqaat.activity.HomeActivity”,”AndroidMobileCapabilityType.SYSTEM_PORT”:”4760″,”newCommandTimeout”:0,”platformVersion”:”7.0″,”automationName”:”uiautomator2″,”udid”:”10160adb37840903″,”platformName”:”Android”,”deviceName”:”Galaxt Note5″},{},[{“desiredCapabilities”:{“appPackage”:”com.boutiqaat.boutiqaat”,”appActivity”:”com.boutiqaat.boutiqaat.activity.HomeActivity”,”AndroidMobileCapabilityType.SYSTEM_PORT”:”4760″,”newCommandTimeout”:0,”platformVersion”:”7.0″,”automationName”:”uiautomator2″,”udid”:”10160adb37840903″,”platformName”:”Android”,”deviceName”:”Galaxt Note5″}},{“requiredCapabilities”:{}}]]
[debug] [BaseDriver] Event ‘newSessionRequested’ logged at 1493903952988 (16:19:12 GMT+0300 (Arab Standard Time))
[Appium] Creating new AndroidUiautomator2Driver (v0.3.2) session
[Appium] Capabilities:
[Appium] appPackage: ‘com.boutiqaat.boutiqaat’
[Appium] appActivity: ‘com.boutiqaat.boutiqaat.activity.HomeActivity’
[Appium] AndroidMobileCapabilityType.SYSTEM_PORT: ‘4760’
[Appium] newCommandTimeout: 0
[Appium] platformVersion: ‘7.0’
[Appium] automationName: ‘uiautomator2’
[Appium] udid: ‘10160adb37840903’
[Appium] platformName: ‘Android’
[Appium] deviceName: ‘Galaxt Note5’
[BaseDriver] The following capabilities were provided, but are not recognized by appium: AndroidMobileCapabilityType.SYSTEM_PORT.
[BaseDriver] Session created with session id: 53f37927-10aa-4972-9ade-58ed1de96bfe
[UiAutomator2] UIAutomator2 Driver version:0.3.2
[debug] [AndroidDriver] Getting Java version
[AndroidDriver] Java version is: 1.8.0_111
[ADB] Checking whether adb is present
[ADB] Using adb.exe from C:\Users\sanjay\AppData\Local\Android\sdk\platform-tools\adb.exe
[AndroidDriver] Retrieving device list
[debug] [ADB] Trying to find a connected android device
[debug] [ADB] Getting connected devices…
[debug] [ADB] 2 device(s) connected
[AndroidDriver] Using device: 10160adb37840903
[ADB] Checking whether adb is present
[ADB] Using adb.exe from C:\Users\sanjay\AppData\Local\Android\sdk\platform-tools\adb.exe
[debug] [ADB] Setting device id to 10160adb37840903
[AndroidDriver] No app sent in, not parsing package/activity
[ADB] Getting device platform version
[debug] [ADB] Getting connected devices…
[debug] [ADB] 2 device(s) connected
[debug] [ADB] Running ‘C:\Users\sanjay\AppData\Local\Android\sdk\platform-tools\adb.exe’ with args: [“-P”,5037,”-s”,”10160adb37840903″,”shell”,”getprop”,”ro.build.version.release”]
[debug] [ADB] Getting connected devices…
[debug] [ADB] 2 device(s) connected
[debug] [ADB] Running ‘C:\Users\sanjay\AppData\Local\Android\sdk\platform-tools\adb.exe’ with args: [“-P”,5037,”-s”,”10160adb37840903″,”shell”,”wm”,”size”]
[debug] [ADB] Getting connected devices…
[debug] [ADB] 2 device(s) connected
[debug] [ADB] Running ‘C:\Users\sanjay\AppData\Local\Android\sdk\platform-tools\adb.exe’ with args: [“-P”,5037,”-s”,”10160adb37840903″,”shell”,”getprop”,

 

Thanks,

Sanjay

Default Asked on May 5, 2017 in Appium.
Add Comment
  • 0 Answer(s)
  • Your Answer

    By posting your answer, you agree to the privacy policy and terms of service.