RE: emulator: ERROR: x86 emulation currently requires hardware acceleration!

Getting below mention error on setting up Android Emulator for Appium Automation Testing:

emulator: ERROR: x86 emulation currently requires hardware acceleration!

Please ensure Intel HAXM is properly installed and usable.
CPU acceleration status: HAX kernel module is not installed!

Lakshay Sharma Professor Asked on July 7, 2015 in Appium.
Add Comment
2 Answers

Hi,

Open android sdk manager and install below option under Extras folder and Under API level for which we want to create emulator.

Intel x86 Emulator Acceleartor [HAXM Installer]

As per my understanding this is image of emulator which we try to create, so until it is available we do not have option to create it

emulator -avd  <Emulator Name> will then open created emulator

Supporter Answered on July 9, 2015.
Add Comment

Your Answer

By posting your answer, you agree to the privacy policy and terms of service.